Petite astuce pour Xorg-Server 1.9 et les pilotes propriétaires nVidia

La version 1.9 de Xorg-Server vient d’être rendu disponible sur Archlinux. Si on utilise le pilote propriétaie nVidia, il peut y avoir un problème de lancement de Xorg.

En me basant sur des infos trouvé sur le paquet AUR xorg-server-dev, il faut rajouter le fichier 10-ServerFlags.conf dans /etc/X11/xorg.conf.d/ avec le contenu suivant :

Section « ServerFlags »
Option « IgnoreABI » « True »
EndSection

Et normalement, après la mise à jour de Xorg-server en version 1.9, aucun problème 😉

Ci-gît un bug vicieux.

C’est la fin de l’histoire du bug vicieux qui m’empoisonnait la vie d’utilisateur de ma Frugalware Linux. Grâce à la ténacité d’Hermier, la solution a été enfin trouvée.

Pour faire rapide, si vous avez un problème de compositing avec un circuit nvidia et xorg-server 1.7.6, il faudra ajouter ceci au début de votre fichier /etc/X11/xorg.conf

Section « Module »
SubSection « extmod »
Option « omit xfree86-dga »
EndSubSection
EndSection

Et le compositing reviendra à la vie. Ouf 😉

L’histoire – en cours – d’un bug vicieux : le bug 4145 de la Frugalware Linux.

Comme toute histoire, il faut un commencement. Ce commencement, c’est le 17 mars qu’il arrive.

Ce jour là, arrive la version 1.7.6 du paquet xorg-server. Faisant la mise à jour du paquet et redémarrant ma session, je m’aperçois que compiz ne se lance plus. J’avais déjà parlé de ce problème.

Horreur, plus de fenêtres molles, de zolies animations lors de la réduction des fenêtres.

Je ferme l’icone de Fusion-Icon qui s’occupe de lancer Compiz, et je la relance en utilisant le terminal et je tombe sur un simple message d’erreur :

fred@frugalware:~$ fusion-icon &
[1] 3493
fred@frugalware:~$ * Detected Session: gnome
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz (core) - Fatal: No damage extension

J’ouvre donc un rapport de bug, histoire de faire connaître le problème, le bug 4145.

Mon premier réflexe est de vérifier si un bug de ce style est connu, et je tombe sur quelque chose d’équivalent sur le suivi de bugs de la mandriva sur le bug 57889.

Mais le correctif proposé ne change rien.

Le seul correctif que je trouve, est plus un contournement qu’autre chose : rétrograder la version de xorg-server, en utilisant la 1.7.5 qui fonctionnait parfaitement. Et en la réinstallant, Compiz revient à la vie.

Je me dis alors que ce doit être un bug du pilote propriétaire nvidia, et je me débrouille pour empaqueter la nouvelle version, la 195.36.15. Mais aucun changement quand je repasse à la version 1.7.6 de xorg-server.

Entre temps, devil505 parle de mon problème dans son billet du 20 mars. J’ai droit par la même occasion d’être le premier lauréat du prix Cyrille de la semaine.

Le 23 mars, Hermier qui s’occupe du pilote nvidia se décide à me donner un coup de main. Et depuis 4 soirs, tout a été essayé, en essayant rester exhaustif :

  • Recréer le fichier xorg.conf avec le pilote récent et xorg-server 1.7.6
  • Désactiver xinerama et record dans le fichier xorg.conf
  • Utiliser des versions de xorg-server 1.7.6 avec des correctifs suspects
  • Empaqueter de manière officielle le dernier pilote propriétaire nvidia
  • Utiliser l’option composite de gnome
  • Recompilation de Xorg-Server aussi bien en local qu’avec l’aide de bouleetbil et d’hermier
  • Enlever le module nouveau du noyau à la sauvage
  • Mettre à jour la version de libdrm
  • Recompiler libxdamage
  • Rétrograder dri2proto

Les logs du canal irc #frugalware.fr 25 mars, du 26 mars – , et du 27 mars, liste tout ce qui a été tenté.

Maintenant, je dois avouer que je suis à court d’idées devant un tel bug, aussi vicieux

Mieux vaut en rire qu’en pleurer, au final, et j’espère que ce billet permettra d’apporter des idées nouvelles pour mettre à mort ce bug qui me facilite un brin le transit intestinal dans ma vie d’utilisateur d’informatique libre.

Un espoir serait peut-être l’arrivée de la version 1.8.0 de Xorg-server, prévue pour la fin du mois.

Qui vivra verra !