Guide d’installation d’Archlinux et Gnome : deuxième mise à jour.

Cela faisait quelques temps que je voulais mettre à jour le guide que j’avais rédigé en octobre dernier. Voici donc la 3ième version.

Il se base sur une machine virtuelle Qemu, utilisant Grub 2.0. On obtient un système assez fonctionnel, avec Gnome 3.6.2 au final.

Si vous voulez KDE SC, il faut utiliser les lignes de commandes suivantes :


yaourt -S kde
systemctl enable kdm.service

Pour Xfce avec lxdm ?


yaourt -S xfce4 xfce4-goodies gamin gvfs lxdm
systemctl enable lxdm.service

Ce n’est pas un tutoriel à suivre au pied de la lettre, mais une base pour se dégrossir. Le fichier zip contient :

  • La version odt
  • La version pdf
  • La version ePub
  • La version mobi (pour Kindle)

Le guide en question est sous licence CC-BY-SA 3.0.

Bonne lecture !

Note : une coquille s’est glissée dans le document. Il faut lire :


mount /dev/sda1 /mnt/boot
mount /dev/sda4 /mnt/home

au lieu de :


mount /dev/sda1 /boot
mount /dev/sda4 /home

27 réflexions sur « Guide d’installation d’Archlinux et Gnome : deuxième mise à jour. »

      1. Ce que je comptais faire…

        J’ai justement essayé hier soir, mais impossible de lancer la machine virtuelle.
        Dans l’optique de tester du Arch, j’avais même téléchargé Manjaro et Chakra, mais ce n’est pas la même chose 😉

        Je réessaye ce soir avec ton tuto.

  1. Bonjour,
    J’aimerai l’installer sur 1 seule partition comme ceci :
    -Partition / en /dev/sda7 en ext4
    Comment dois-je m’y prendre ?
    Je ne sais pas comment faire pour bien monter cette partition.
    Merci pour votre aide

  2. Salut Frédéric,

    Petite question hors sujet, si tu devais proposer une distribution basé sur Arch linux laquelle proposerais tu?
    Manjaro, Chakra ou Parabola ?

    Merci d’avance pour ta réponse, et merci surtout pour le guide d’installation.

    @+

    1. Argh, la question qui tue.

      Si tu es fan de KDE, je te conseillerais Chakra Linux sans hésitation. Si tu préfères Xfce ou Cinnamon, Manjaro Linux serait un choix à étudier. Parabola ? C’est Archlinux + un noyau linux libre, quelques paquets spécifiquement libres et puis c’est tout pour schématiser.

      1. Perso, j’ai testé Chakra et elle est vraiment très très bien, mais il lui manque quelques paquets que j’utilise et je ne suis pas fan des bundles. Mais si tu es KDE-centriste, elle est parfaite!

  3. Bonjour,

    J’ai testé Archlinux sous Virtualbox et j’ai rencontré deux problèmes.

    Le premier sur l’installation de « virtualbox-guests-modules » ( paquet introuvable ), a la place j’ai installé « virtualbox-guest-utils ».

    Le deuxième, non résolu, avoir le bon clavier à l’écran de connexion ( GDM ).
    Une idée ?

    En tout cas, merci pour ce super tuto.

    1. Pour l’histoire de virtualbox, je plaide coupable, une faute de frappe.

      Pour le deuxième point, il faut le configurer dans Gnome lui-même, dans les paramètres systèmes.

      Et de rien si j’ai pu aider.

      1. Oui ça fonctionne pour le clavier en allant dans les paramètres système.
        Par contre lors du premier démarrage après l’installation on est en qwerty donc suivant le mot de passe renseigné on peut se retrouver bloqué.

        Je me demande si ce problème est spécifique à virtualbox ?

          1. J’ai mis la même chose dans /etc/vconsole.conf.
            J’ai testé aussi avec fr-latin1, sans le FONT, mais ça marche pas, toujours qwerty dans le gestionnaire de connexion que se soit Gnome ou Kde

          2. J’avoue que je ne comprends pas. Y a-t-il un fichier /etc/X11/xorg.conf.d/00-keyboard.conf ?

            Si oui, son contenu ressemble-t-il à ceci ?

            # Read and parsed by systemd-localed. It's probably wise not to edit this file
            # manually too freely.
            Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "fr"
            EndSection

  4. Ce tuto gagnerait à avoir encore plus de visibilité car toujours aussi bon et détaillé.
    Peut-être un lien permanent sur ton blog bien en évidence ou le pdf dans un site Documentation 🙂

    1. Encore moi, j’ai créer le fichier 00-keyboard.conf avec tes informations, le problème est résolu.
      Je te remercie du temps que tu m’as accordé.

  5. Excellent guide, j’ai toujours eu « peur » de sauter le pas malgré le fait qu’Arch me faisait envie, je me suis lancé via vos explications, et j’ai une Arch fonctionnelle sous Virtualbox !

    Seul « soucis », dans virtualbox, soit je désactive l’accélération 3D, et dans ce cas l’interface est un peu saccadée. Soit je l’active et c’est très fluide, mais j’ai pas mal d’artefacts désagréables dans l’interface (scintillements, fond d’écran qui fait n’importe quoi…)

    J’ai installé virtualbox-guest-modules ET virtualbox-guest-utils (sans trop savoir la différence d’ailleurs), j’ai utilisé le paquet xf86-video-vesa (peut être est ce ça le problème, il y en avait peut être un spécifique pour virtualbox que je n’ai pas vu ?).

    Et j’ai bien mon fichier vbox.conf qui contient les 3 lignes nécessaires (d’ailleurs, petite coquille dans le PDF, c’est dans le dossier modules-load.d et non pas modules.load.d comme il est écrit, si ça peut en aider certains).

    Donc je ne sais pas trop… Si vous avez une idée du problème.

    Dans tous les cas un grand merci, votre blog est désormais dans mes favoris je viendrais vous y lire régulièrement !

    1. Seul « soucis », dans virtualbox, soit je désactive l’accélération 3D, et dans ce cas l’interface est un peu saccadée. Soit je l’active et c’est très fluide, mais j’ai pas mal d’artefacts désagréables dans l’interface (scintillements, fond d’écran qui fait n’importe quoi…)

      C’est normal ce genre d’artéfacts. Mais cela ne tue en rien l’utilisabilité de l’ensemble.

      J’ai installé virtualbox-guest-modules ET virtualbox-guest-utils (sans trop savoir la différence d’ailleurs), j’ai utilisé le paquet xf86-video-vesa (peut être est ce ça le problème, il y en avait peut être un spécifique pour virtualbox que je n’ai pas vu ?).

      Il n’y en pas, mis à part les additions invitées.

      Et j’ai bien mon fichier vbox.conf qui contient les 3 lignes nécessaires (d’ailleurs, petite coquille dans le PDF, c’est dans le dossier modules-load.d et non pas modules.load.d comme il est écrit, si ça peut en aider certains).

      Faudra que je me modifie 😀

      Dans tous les cas un grand merci, votre blog est désormais dans mes favoris je viendrais vous y lire régulièrement !

      Merci, c’est toujours agréable à lire 🙂

  6. Bonsoir,

    Je vous ai laissé un message hier, pour vous féliciter et vous indiquer que tout fonctionnais bien, sur Virtualbox.

    Ce soir, j’ai tenté de réaliser l’installation sur VMware, que je préfère pour diverses raisons, principalement niveau performances et drivers vidéos (afin de résoudre éventuellement les petits artefacts que j’ai sous VB).

    J’ai donc resuivi votre PDF à la lettre, sauf qu’à la place d’installer le driver video vesa, j’ai installé celui de vmware. J’ai suivi également toutes les indications de cette page : https://wiki.archlinux.org/index.php/Kernel_Modules#Loading en installant Open-VM-tools, et configuré xorg comme indiqué.

    Problème, dès que je boot, ça bloque à cet endroit : http://image.noelshack.com/fichiers/2013/11/1363373492-sans-titre.png (il indique que ça a mal été redémarré, car j’ai essayé plusieurs fois et à chaque fois je me vois obligé d’éteindre la machine de façon brutale vu que je n’ai plus la main sur rien)

    J’ai rebooté sur le live CD, j’ai monté les partitions sur lesquelles j’ai précédemment tout installé, et je suis rentré dans mon système avec arch-chroot /mnt.

    J’ai pourtant tout vérifié attentivement, ainsi que mes fichiers de configuration, tout me semble pourtant OK 🙁 Quelque chose doit m’échapper, si vous avez une piste (et le temps de m’aider), ça serait fort sympathique 😀 Merci par avance.

    1. J’avoue que je n’ai plus utilisé VMWare depuis… un certain nombre d’années.

      Il doit surement y avoir un problème au niveau de xorg. Il faudrait essayer d’entrer dans une console texte via alt-f2.

      Et de voir s’il n’y a pas des messages lié à xorg dans /var/log/

      1. Le soucis est que je ne peux absolument rien faire, une fois que j’ai les messages qui sont indiqués sur ma capture d’écran, le curseur disparaît et je n’ai plus la main sur rien. C’est vraiment étrange que je n’ai pas accès au shell ni la main sur rien. J’ai essayé de faire la même installation sous vmware avec le driver x86-video-vesa, et le système boot correctement. Mais ça n’est pas fluide et l’accéleration 3D n’est pas supportée.

        C’est à partir du moment ou j’installe les drivers x86-video-vmware que ça plante au démarrage, même en configurant Xorg comme indiqué dans le Wiki.

        Bon sinon je ferai sans, je vais me dégoter un HDD que je rajouterai à ma tour et sur lequel j’installerai Arch pour avoir un Dual boot. C’est juste que je n’aime pas trouver des solutions aux problèmes, ça m’empêche de dormir 😀 Merci tout de même.

        1. Dernier message et j’arrête de spamer 😉

          En fait c’est probablement bien un soucis avec Xorg, je suis rentré dans mon système, et lorsque j’essaye de démarrer startx pour tester l’affichage, il commence à le démarrer et plante de la même manière qu’au démarrage. Il y a effectivement plusieurs info sur xorg dans /var/log/, mais j’avoue avoir du mal à les déchifrer. Bon je vais continuer à chercher, ne serait ce que par curiosité, sinon je poserai la question sur le forum d’Archlinux. Bonne soirée !

Les commentaires sont fermés.