L’installateur graphique de la Frugalware Linux 1.3pre1 : la route de l’Enfer est pavée de bonnes intentions.

La première préversion de la Frugalware Linux 1.3 est sorti il y a deux semaines environ. J’ai voulu voir ce que donnait l’installateur graphique, une des grandes nouveautés de cette mouture de la Frugalware Linux.

J’ai utilisé wget pour récupérer l’image d’installation.

[fred@fredo-arch download]$ wget -c http://www7.frugalware.org/pub/frugalware/frugalware-testing-iso/frugalware-1.3pre1-i686-gui.iso
–2010-05-15 21:01:32– http://www7.frugalware.org/pub/frugalware/frugalware-testing-iso/frugalware-1.3pre1-i686-gui.iso
Résolution de www7.frugalware.org… 88.191.250.131
Connexion vers www7.frugalware.org|88.191.250.131|:80…connecté.
requête HTTP transmise, en attente de la réponse…200 OK
Longueur: 49180672 (47M) [application/octet-stream]
Sauvegarde en : «frugalware-1.3pre1-i686-gui.iso»

100%[======================================>] 49 180 672 697K/s ds 71s

2010-05-15 21:02:43 (679 KB/s) – «frugalware-1.3pre1-i686-gui.iso» sauvegardé [49180672/49180672]

Pour des raisons techniques, j’ai été obligé d’utiliser l’option « -vga std », sinon le xorg ne se lance pas, et donc pas d’interface graphique.


[fred@fredo-arch download]$ qemu-img create -f raw disk.img 32G
Formatting 'disk.img', fmt=raw size=34359738368
[fred@fredo-arch download]$ kvm64 -hda disk.img -cdrom frugalware-1.3pre1-i686-gui.iso -vga std -boot d &

Ensuite, c’est fwife qui nous accueille.

Donc, on choisit la langue, les dépots, le partionnement du disque.

Ensuite, arrive le choix des paquets. J’ai hésité, puis j’ai choisi Gnome. Cette hésitation a du être source d’un bug que j’ai rencontré par la suite.

Arrive ensuite la longue récupération et installation des paquets. On installe après le chargeur de démarrage, on définit le mot de passe du compte root, on crée un utilisateur pour la vie de tous les jours, on configure l’heure.

Un des derniers panneaux propose de configurer la souris et X. Etrangement, seul xdm est proposé.

Une fois l’installation finie, manque de chance, on ne peut pas se connecter, xdm bloquant le chargement de l’interface graphique.

Qu’à cela ne tienne. J’ai redémarré la machine virtuelle en omettant volontairement l’option « -vga std » et en redémarrant sur le CDRom, ce qui m’a laissé la main libre pour pouvoir modifier le fichier /etc/sysconfig/desktop, donc la ligne de commande suivante :


kvm64 -hda disk.img -cdrom frugalware-1.3pre1-i686-gui.iso -vga std -boot d &

J’ai donc créé un répertoire, puis j’ai monté la partition /dev/sda1 (celle contenant la frugalware, et j’ai navigué jusqu’à pouvoir éditer le fichier /etc/sysconfig/desktop.

Donc, les lignes de commandes suivantes :


mdkir disk
mount /dev/sda1 /disk
cd disk/etc/sysconfig
vi desktop

J’ai commenté la ligne contenant xdm et décommenté celle concernant gdm.

Au redémarrage suivant, on m’annonce que je n’ai pas gdm installé 🙁

Qu’à cela ne tienne, je me connecte en root, et puis je tape la commande magique :


pacman-g2 -S gdm

Et une bonne partie de Gnome s’installe, comme si elle n’avait pas été installée auparavant ! Un bug de fwife ? Ou une mauvaise manipulation de ma part lors du choix des paquets ?

Quoiqu’il en soit, je rédémarre une nouvelle fois, mais cette fois, gdm ne se charge pas. Soit je tombe mal – ce qui n’est pas impossible étant donné que la Frugalware est en plein branle-bas de combat – soit il y a du avoir une c****** dans le potage quelque part ailleurs.

L’installation graphique n’est pas encore super au point, mais étant donné que ce n’est qu’une pré1, d’ici la version finale (septembre ou octobre prochain), l’outil sera au point.

Comme disait une célèbre publicité pour un fabriquant de compatible PC au début des années 1990 : « A suivre » 😀

9 réflexions sur « L’installateur graphique de la Frugalware Linux 1.3pre1 : la route de l’Enfer est pavée de bonnes intentions. »

  1. Merci pour ce test 🙂
    En effet c’est la première fois que fwife est intégré à une image iso officielle donc y’a encore des erreurs de jeunesse malgré tout le chemin parcouru par Elentir son concepteur.
    Encore merci je relaye ton billet à Elentir pour la correction de bug 🙂

  2. j’aurai tendance à dire que c’est le même bug que j’ai pu rencontrer via qemu à savoir une installation partielle des paquets, on tourne un peu en rond du côté des serveurs.

Les commentaires sont fermés.