2 bugs à la c** en une semaine sur ma Frugalware-current…

En l’espace de quelques jours, j’ai été confronté à deux bugs à la c** sur ma Frugalware Linux, en version current. Je connais les « risques et les joies » d’une distribution en rolling-release, donc c’est assez normal que cela arrive. Mais je dois être comme Cyrille Borne, je dois attirer les bugs 😉

Et les deux sont suite à des mises à jours majeures de paquets. Le premier, le bug 4145 concerne un bug lié au passage à xorg-server 1.7.6 qui tue purement et simplement la composition sous Xorg avec le pilote propriétaire Nvidia. Après avoir rapporté le bug et posté un message sur le forum francophone de la Frugalware, je ne suis pas le seul à être apparemment concerné.

Ce n’est pas trop ennuyeux dans l’absolu, mais  quand on est devenu accroc aux fenêtres molles de Compiz-Fusion

L’autre bug que j’ai rapporté est cependant plus handicapant, car il empêche purement et simplement d’imprimer quoique ce soit avec mon imprimante HP PhotoSmart C3180. C’est le bug 4148. Devant imprimer un document, j’ai alors essayé de lancer l’outil HP-Toolbox, mais rien ne s’affichait. En lançant l’outil en ligne de commande, j’ai droit à ceci :


fred@frugalware:~$ hp-toolbox &
[1] 32677
fred@frugalware:~$ Traceback (most recent call last):
File "/usr/bin/hp-toolbox", line 39, in
from base import status, tui, module
File "/usr/share/hplip/base/status.py", line 40, in
import hpmudext
ImportError: libnetsnmp.so.15: cannot open shared object file: No such file or directory

Un fichier manquant ? En rétrogradant le paquet net-snmp, comme par miracle, l’outil HP-Toolbox est redevenu fonctionnel…

C’est quand même étrange qu’un bug aussi gros que celui-ci soit passé inaperçu durant près d’une semaine, car le paquet net-snmp fautif a été mis en ligne le 14 mars

Au moins, les bugs ont été signalés, on verra le temps qui sera mis pour les faire disparaître 😉

4 réflexions sur « 2 bugs à la c** en une semaine sur ma Frugalware-current… »

  1. Pour le bug compiz je sais pas mais hplip je pense savoir.

    Il suffit de rebuilder hplip contre la dernière version net-snmp surement.

    Je te corrige çà ce soir, je suis au taf là.

    1. J’ai vu cela. Par contre qu’il fut en vie durant près d’une semaine, c’est cela le plus « bizarre » dans l’histoire, à croire que peu d’utilisateurs de Frugalware-current ont une imprimante HP ! 🙂

  2. A la base il y a peu d’utilisateurs de Frugalware je pense. 😀

    Ce genre d’erreur avec un fichier .so est c’est courant sur -current, faut juste rebuilder le paquet avec la dernière version de la dépendance en question, si t’en retrouve continue à faire des rapports de bugs ou avertit moi directement si c’est mes paquets. 😉

Les commentaires sont fermés.