Guide d’installation d’Archlinux, version de janvier 2018.

Voici la cinquante-et-unième version du tutoriel pour installer une Archlinux, que ce soit avec une machine virtuelle, utilisant un Bios ou un circuit UEFI. Cette version rend obsolète celle de décembre 2017.

Désolé pour le léger délai concernant la publication de cette version du guide !

Si vous avez besoin d’une image ISO en 32 bits, le projet archlinux32 vous en proposera une.

Côté environnements : Gnome 3.26.2, Plasma 5.11.x, Xfce 4.12.0 et Mate-Desktop 1.18.0 en gtk3.

NB : si vous voulez faire une installation avec l’UEFI, il faut utiliser cgdisk, gfdisk ou gparted, et créer un partitionnement GPT. Sinon, ça plantera !

Ce n’est pas un tutoriel à suivre au pied de la lettre, mais une base pour se dégrossir. Le fichier au format zip contient :

  • La version odt
  • La version pdf
  • La version ePub
  • La version mobi (pour Kindle)

Le guide en question est sous licence CC-BY-SA 4.0 à compter du mois de mai 2016.

Bonne lecture et n’hésitez pas à me faire des retours en cas de coquilles !

9 réflexions sur « Guide d’installation d’Archlinux, version de janvier 2018. »

  1. Salut Fred,

    Tout d’abord, je tenais à te remercier pour ton guide. Il m’a bien servi pour concocter le mien il y a quelques mois. Voici quelques erreurs que j’ai pu relever :

    Page 14 : « NOTE 2 : netctl et networkmanager rentrent en conflit et ne doivent pas être
    utilisé en même temps. » -> utilisés*

    Page 15 : « On tape les lignes de commande suivantes pour mettre à jour
    les dépôts et installer yaourt un outil qui va nous simplifier grandement la vie. » -> je rajouterais une virgule après « yaourt ».

    Page 19 : « Et enlever le # sur la ligne qui suit. La séquence de touches « Échap : w et q »
    permet de converser la modification. » -> je suppose que tu voulais dire « conserver » ?

    Rien de bien méchant en somme.

    Amicalement.

  2. Merci pour cette nouvelle version, j’ai lu que Yaourt est toujours utilisé et pas encore Trizen ?
    Il y a bien longtemps que je n’ai démarrer la Archlinux sur le vieux PC, ce m’étonnerait pas d’avoir quelques surprises 😀
    Bonne rentrée dans cette nouvelle année 2018.
    A pluche.

  3. Hello, j’ai compris ce que tu voulais dire car pour aller facilement dans aur au debut de mon installation, par exemple pour avoir pamac et bien le plus simple est d’installer yaourt qui est dans le depot archlinux.fr je crois.
    Sinon pour les 2 nouvelles failles qui touchent tout le monde je pense que tu vas peut etre en parler bientot. La communauté Linux réagit vite puisque la mise a jour est prévu pour le 9 janvier je pense.

    1. Pour les failles en question, je n’ai qu’une chose à dire : j’attends que tout cela retombe, car tout et n’importe quoi est dit en ce moment.

      Quant à leur utilisation, elle est franchement réduite, vu le nombre de comptes ouverts sur Facebook, Instagram ou encore Snapchat…

  4. Alors moi j’ai une question concernant le swap

    Une fois monte rien a dire mais quand on fait umount -R /mnt et qu’on reboot je ne sais pas si tu l’as vu mais y’a un message en rouge qui indique que le swap n’a pas pu etre demonte comme il se doit.

    Question > ne faudrait-il pas faire swapoff (je ne connais pas la commande propre) avant de reboot ?

    – Remarque: pour le driver AMD il y a aussi xf86-video-amdgpu (d’ailleurs AMD veut renouveler les liens avec Linux apres avoir rompu)

    Autre question > Pourquoi attendre la version 3 de VLC ? Quodlibet a tendance a merde apres plusieurs utilisation j’ai du le virer pour installer clementine.

    En tout cas merci pour le guide

    1. Pour le swap, ce serait une bonne idée. Mais cela ne provoque aucun problème par la suite.

      Pour AMD, le serveur xf86-video-amdgpu concerne uniquement les modèles récents, non ?

      VLC 3 sera en QT5, presque entièrement réécrit au niveau moteur, donc meilleur. Pour Quodlibet, cela fait 3 ans que je l’utilise sans problème. Et comme je le précise, ce sont des indications que je donne.

      1. D’accord merci pour l’info concernant pour le swap

        Pour le xf86-video-amdgpu ca vise les GPU 3eme et 4eme gen, les generations 1 et 2 c’est plus experimental. D’apres le wiki d’arch.

        Donc le vlc 3 qt5 pourrait etre tres interessant il me tarde de le voir.

Les commentaires sont fermés.